Как "спрятать" данные? #133654


#0 by Diter
Заказчик - медицинская клиника. Заказали небольшую конфу по учёту. Задали вопрос - как обеспечить врачебную тайну. Вот сижу - думаю.... Они хотят, чтобы заходя в базу нужно было вводить кроме пароля в 1С ещё и пароль доступа к данным - нет второго пароля - с пациентами не работаешь, но отчёты суммарные видишь (по болезням, по врачам, по вызовам и по бабкам). Ещё, если не введён второй пароль и была попытка открыть справочник "больные" то посылать за горизонт, а документах, которые можно просматривать вместо фамилий больных видеть либо крокозяблики либо пустое место..... Ещё остаётся тупое копирование инфы и взлом защиты паролем. Вот такая задача.... И чего вы по этому поводу думаете? Как сделать так, чтобы инфа в dbf хранилась в крокозябликах, а при работе и вводе пароля - віводилась в человеческих буквах? Ресь только о строковых реквизитах. Скрывать нужно именно их.....
#1 by КонецЦикла
Имхо бесполезняк Только на дурачку
#2 by Diter
Я вот подумал о перелопачивании всех элементов всех справочников (при вводе пароля № 2) и восстановлении инфы из крокозябликов. При завершении работы - обратный процесс
#3 by Стерва-бух
и зачем вопрос под выходные задавать? народ же в основном отдыхать будет
#4 by Diter
Сегодя только четверг!!!! Или в России пятница объявлена выходным?
#5 by goodfella
Да.
#6 by Стерва-бух
у нас 4 ноября праздничный выходной день
#7 by КонецЦикла
2 У них какое-то освобождение от чего-то У нас 7-го праздник
#8 by Diter
В честь чего?
#9 by goodfella
У меня ДР.
#10 by КонецЦикла
#11 by Diter
У меня тоже ;))
#12 by Стерва-бух
День народного единства
#13 by goodfella
Читал?
#14 by Grey74
Как вариант: 1. База SQL 2. Метаданные - права доступа через права, или через глоб переменную определяющую введен или нет пароль при НачалеРаботыСистемы иль в ней иль обработку 3. Основное представление спр. больные - в виде кода, тогда где ссылки (наприм документы), да и отчеты - отображаются в виде кода, а имена только в справочнике посмотреть можно
#15 by goodfella
+13
#16 by SKrin
Внимание! В РФ использование криптографии требует лицензирования ФАПСИ. Использование криптографических средств без данной лицензии является преступлением. О как!
#17 by Diter
пункты 1 и 2 - понятно - банальное разделение прав доступа пункт 3 не подходит - не будет девочка в регистратуре на цифры смотреть - ей фамилии в документах и отчётах нужны
#18 by Diter
пофик - На Украине - пофик что запрещено в России ;)
#19 by Diter
Что то я не могу открыть не первую не вторую ссылку. Если можно - запиши в виде файлов и кинь на мой ящик.....
#20 by SKrin
а зачем сразу весь можно запоминать пароль и обрабатывать справочник во время открытия и закрытия/сохранения т.е. данные на диске у тебя будут постоянно в крязябрах
#21 by Diter
Как ты думаешь что дольше работает - запрос по остаткам каждого товара или запрос сразу по всем товарам? Аналогия понятна?
#22 by goodfella
Ок.
#23 by goodfella
Вот тут еще:
#24 by SKrin
аналогии не вижу вообще массовая обработка чревата последствиями, да и в дбфках у тебя данные сразу прозрачными становятся а если обрабатывать "на лету", то нагрузки на базу нет совсем, т.к. читаешь и записываешь элемент ты в обычном порядке. Нагрузка идет на кодирование/декодирования, да и то небольшая, т.к. достаточно не слишком сложного шифрования ЗЫ: а вообще дело твое...
#25 by Diter
как мне прочитать при открытии документа, формировании отчёта, и других действий не связанных напорямую с выбором из справочника.....
#26 by SKrin
при формировании отчета проблем особых нету а вот с документами придется повыеживаться может быть сохранять свои "ссылки" на реквизиты, а при открытии преобразовавать и подставлять ссылочные данные
#27 by Guk
Ниасилишь ИМХО. Надо спеца по защите звать...
#28 by ШтушаКутуша
в составе винды есть такая утилита cipher,пошукай на , как с ней работать,ну и там...разделение баз,то се...
#29 by Diter
Нет. Всё-таки сделаю так При закрытии программы - перелопачивание всех "критичных" справочников внешней обработкой закрытой КЗК на предмет замены строковых реквизитов. При открытии запрос пароля № 2. Если пароль введён - значит обратный процесс перевода справочников из крокозябликов в нормальные строки.... Проблемы с доступом к информации с момента ввода пароля до момента закрытия программы (когда она открыта) - решаем оргметодами..... - доступ к компу, запугивание персонала и т.п.
#30 by SKrin
а база однопользовательская?
#31 by Diter
Возможно - сетевая. От двойной обработки защита стоять будет. Соответственно "закрываться" данные будут при последнем выходе из базы...
#32 by Diter
(+31) Правда вопрос - как определить, что это "последний русский" в базе?
#33 by Diter
(++31) И ещё - получается, что зайдёт один человек зная пароль № 2 и откроет данные для всех, кто после него заходит - значит не катит такой вариант - а было так просто..... Попробую подумать над предложением SKrin......
#34 by Diter
А с другой стороны - если установить ограничение на однопользовательскую базу - всё пучком... Завтра буду говорить с заказчиком.......
#35 by КонецЦикла
Пока не просек тему, но обрабатывать что-то при закрытии имхо не лучшая идея... ...всяко может случиться Надо подумать над тем, как не обрабатывать? А еще кроме фамилии там и личные данные могуть быть - типа номер паспорта, адрес и проч. - узнать фамилию по этим данным - не проблема
#36 by Diter
Эти данные тоже будут закрываться - строки ведь..... понравилась идея насчёт "прокладок" между реквизитами документов и реальными "закрытыми" данными из справочника.... думаю....
#37 by MMF
фу... в сад... А ведь заказчику скажет, что все вопросы с доступом решены
#38 by koord
А на 8 такое можно сделать. С помощью RLS.
#39 by Sonic_vlad
чаво чаво?
#40 by Diter
Ваши предложения где? Что нибудь конструктивное есть кроме "фу"?
#41 by 427
поставленная задача на 1С не выполнима... в силу отсутствия необходимого инструментария... РЛС здесь мало поможет...
#42 by Фигня
У нас дир хохол. Так что празнуем по-хохляцки. . 1. Если "на лету", "при открытии", "при закрытии", то нужен мощный УПС. Причем Смарт-УПС. Иначе чуть-что с электричеством и "ку-ку". 2. "На лету" будет проблема с запросами. 3. Чем плохи разные набора прав с доп. проверками в коде? А базу на криптодиск кинуть. Если кто сопрет, то сразу ясно кто. . Для прога, знающего не только 1Сик предложил бы иное средство. ВБ там, Дельфи, Фокс. На Яве, к примеру, есть средства автокриптографии. Сроки разработки, правда, взлетят. Да и программировать нужно уметь тож. Но это так, в порядке фигни.
#43 by skunk
а ведь Пит прав... как ни странно...
#44 by 427
как пример такой системы - ИТС или Большая советсвкая энциклопедия - файлы БД шифрованные или энциклопедия Кирилла и Мефодия или куча иных систем с криптованной базой...
#45 by 427
я всегда прав... как ни странно...
#46 by skunk
да.. да... да... там очень сложная система ... криптования... почти все вордом открывается...
#47 by Guk
Люди не могут правильно формализировать проблему. Создать её вербальную модель. Естесственно в этом случае, в игру вступают делитанты...
#48 by skunk
и что самое страное... это срабатывает
#49 by Diter
Ну в общем то общее настроение по данном теме понятно.... только что от клиента - будем разруливать правами..... Всем спасибо. Особенно тем, кто высказывал аргументированное мнение. остальным - и вам спасибо что зашли.....
#50 by 427
фигня-с... поимеют
Тэги:
Ответить:
Комментарии доступны только авторизированным пользователям

В этой группе 1С

Back to top