Подскажите в чем ошибка #227551


#0 by tata
КонецПроцедурыЭто вопрос из сертификационного задания, подскажиет почему при построчном проведении сообщить("на складе"+текостаток);сообщает одно и тоже количество, хотя как я понимаю должен сработать временный расчет и кол-во должно уменьшаться, при выборе из списка(как указано в задании)кол-во действительно уменьшается.
#1 by Sasha
Странная обработка проведения какая-то %
#2 by Sasha
(+1)ну это так, к слову )По делу: у тебя остаток изменяется, а содержимое переменной текОстаток нет
#3 by Harleq
Ужос, вынеси временный расчет за цикл!
#4 by pit
написано в стиле создателей конф, где итоги на справочниках....
#5 by Макс 1С
РассчитатьРегистрыНа(ТекущийДокумент); - НА начало события...а ваще конечно код бредовый....
#6 by tata
Нормальная обработка проведения, а как еще реализовать. необходимо реализовать режим допроведения документа (уже проведенные строки не должны проводиться повторно!) с поддержкой в актуальном состоянии временного расчета регистра с учетом уже записанных при пробитии предыдущих чеков движенийНу кто нибудь ответит так почему текостаток не изменяется
#7 by KUBIK
А НоваяСтрока к чему????
#8 by Sasha
ты думаешь, что это заработает???зы. ответ на твой вопрос в
#9 by Sasha
(+8)Попробуй просто перепровести документ, без изменения
#10 by Drovaru2
КонецЕсли 2 раза(!) А само Если только 1 раз.Далее Проведен,это что проверка проведен документ или нет? Если да то такую проверку надо ДО цикла ставить. Остальное тебе написали: про временный расчет и про начало события.
#11 by tata
да в задании надоВ случае успешного списания серий медикаментов, процедура пробития чека в конце своей работы должна изменить пустое значение в графе “№чека” на следующий по порядку номер.я и спрашиваю, в чем ошибка
#12 by tata
Проведен это реквизит Т.Ч., чтоб допроводить строки, а проведенные не перепрводить
#13 by Макс 1С
я тебе в 5 написал, какая буква не понтяная???
#14 by Drovaru2
Ой туплю, извиняюсь, код не смог сразу прочитать. Конечно же проверки Если...КонецЕсли закрыты правильно
#15 by Sasha
Напиши-ка ты задание целиком. Толку больше будет
#16 by Макс 1С
я плачу с вас..... если - конецесли....вопрос почему остаток всегда один и тот-же.... неужели при отсутсвии конецесли - будет хоть какой-нибудь остаток?! - ошибка будет!!!!
#17 by Drovaru2
Ответ в
#18 by Drovaru2
Блин, не захожу сегодня на этот форум - рушил отвлечься в башке своя задач крутится. Уважаемый Макс 1С, вы действительно правы: "НА начало события..."
#19 by Гуня
Вроде как новая строка добавляется в цикле, поэтому и остаток не меняется. Тогда почему не зацикливает?
#20 by Макс 1С
я щас начну рыдать.... какая связь между остатком в регистре и добавлением новой строки в документе?!
#21 by Гуня
выборка в цикле каждый раз выбирает пустую строку добавленную в предыдущем цикле.
#22 by Макс 1С
ты считаешь, что у неё (него?) всегда ноль показывает, или есть остаток по несущесвтующему товару (строка то не заполняется)?
#23 by Гуня
Хрен знает что показывает, но получается по логике, что значения строк не меняются, только не пойму, почему не зацикливает.
#24 by Макс 1С
потому что тут код не весь.....Если не закрыт, да и других косяков полно - если код as is - он не будет работать по причине ошибок....
#25 by Макс 1С
+ а не зацикливается, он по тому, что на момент ВыбратьСтроки - строк ровно столько сколько в доке и НовыеСтроки - уже не попадают в выборку...
#26 by tata
Спасибо Макс 1С, получилосьРассчитатьРегистрыНа(ПолучитьПозициюТА);
#27 by Ёпрст
А ВыгрузитьИтоги не проще???
#28 by Макс 1С
ващето надо было рассчитатьРегистрыПО......
Тэги:
Ответить:
Комментарии доступны только авторизированным пользователям
Back to top