Как программно узнать имеет ли пользователь право менять дату запрета редак #271514


#0 by gar_den
Есть ДОХЕРА пользователей. Нужно вычислить тех кто может проводить док-ты раньше даты запрета редактирования. как это делается?
#1 by gar_den
как у пользователя определить такую роль?
#2 by gar_den
ау
#3 by IMHO
в документе по правам нельзя пройтись?
#4 by gar_den
как это?
#5 by gar_den
это что в каждом доке делать чтоли?
#6 by у лю 427
если gar_den <> МДАК тогда ПовыситьЗП (50 баксов) иначе gar_den.ГнатьНакуль(10 пинокв) конец если интересно какая ветка работать будет в ЕСЛИ
#7 by gar_den
как выбрать роли пользователя?????
#8 by gar_den
сам разобрался
#9 by gar_den
добрался я до ролей. а как узнать есть ли у данной роли возможность исправить документ датой раньше чем дата запрета редактирования?
#10 by gar_den
эй где все???
#11 by AJ_81
есть справочник "Привилегии ползователей", там и ставятся разрешения
#12 by IronDemon
Код запроса для изменения смотри на нужный документ на предмет
#13 by AJ_81
потом ищи в глобальнике ГлПривилегииПолзователя
#14 by КонецЕсли
В типовой: Если роль<>"ПолныеПрава" то смотреть в РегистреСведений.ГраницыЗапретаИзмененияДанных какая дата прописана для данной роли. Всё уже написано в общемМодуле.ПолныеПрава процедура УстановитьПараметрГраницыЗапретаИзмененияДанных
#15 by gar_den
нифига нет такого
#16 by КонецЕсли
+  где такое? Самописные поди.
#17 by gar_den
все это конечно так, но например если для роли ПолныеПрава установлена дата запрета редактирования, эта роль все равно сможет изменять документы меньшей даты - вот таких пользователей, с такими ролями и нужно вычислить. поэтому мне нужно узнать: может ли роль менять документы с меньшей датой
#18 by Гений 1С
гыгыгы... НачатьТранзакцию Док.Дата=ДатаЗапретаРедактирования-1 Попытка ОтменитьТранзакцию Запустить по всем докам, по всем юзерям.
#19 by gar_den
+ судя по процедуре УстановитьПараметрГраницыЗапретаИзмененияДанных, где есть такое: такую возможность имеет только ПолныеПрава
#20 by gar_den
Это что мне под каждым пользователем вручную заходить?
#21 by КонецЕсли
можно, например, сравнить полученную в роль пользователя с ролью "ПолныеПрава". Но это будет сложно. Лучше сделать как в .
#22 by gar_den
откуда взять ДатаЗзапретаРедактирования?
#23 by КонецЕсли
такую незнаю. в РегистреСведений.ГраницыЗапретаИзмененияДанных есть ресурс "ГраницаЗапретаИзменений" типа дата, который относится к определенной в измерении "Роль" роли. Дата может быть разной для ролей и только если юзеру доступна роль "ПолныеПрава" то на эту дату в регистре - наплевать. Эта дата храниться в "ПараметрыСеанса.ГраницыЗапретаИзмененияДанных" и инициализируется для каждого пользователя в момент запуска 1с. Имя процедуры написано в .
#24 by gar_den
Пробовал - не катит. Программно док-и создает, а интерактивно - нет
#25 by gar_den
+ почему?
Тэги:
Ответить:
Комментарии доступны только авторизированным пользователям
Back to top