Передать данные из формы в модуль формы (вопрос) #6046


#0 by Danila
Есть поле со списком на форме документа, нужно чтобы при нажатии на кнопку "ПРОВЕСТИ" выбранное значение из этого поля передавалось в соответствующую процедуру проведения в модуле документа, подскажите как это реализоывается. Заранее спасибо!
#1 by SnarkHunter
Не нужно этого делать...
#2 by posevin@mail.ru
Почему не нужно, когда нужно. У нас свой документ в котором именно так и нужно. Или предложите другой способ как праильно люди делают...
#3 by SnarkHunter
У вас этот документ всегда интерактивно проводится или программно тоже?
#4 by Valery
А поле не форме это реквизит или переменная?
#5 by SnarkHunter
Если это реквизит, то передавать незачем...
#6 by Warlock
Создай в документе реквизит числовой, можешь его даже на форму не кидать, но при изменении значения в списке заноси в реквизит новое значение. Так, в модуле проведения тебе будет доступно выбранное значение.
#7 by Warlock
Из реквизита список сделать нельзя
#8 by Danila
[4] Это не реквизит, это переменная. В том то свя и проблема. Еслиб это был реквизит, то его значение в модуле бы присутствовало, а мне нужно именно из модуля формы передать переменную в определенную процедуру модуля документа.
#9 by Valery
тогда лучше сделать его реквизитом. К чему голову ломать.
#10 by Danila
[2Warlock_WW] Я как раз так и хотел, но я еще ламер. Как передать значение из этого списка в числовой реквизит при выборе значения из списка.
#11 by laeg
ТО Ну это с какой стороны посмотреть, конечно это в корне не рекомендуется но люди делают, заводят реквезит строка - неограниченной длины, а потом значениеВстроку и значениеИЗстроки ..... Лучше конечно изпользовать реквезит строка для хранения выбранного элемента из СпискаЗначений, с другой стороны как он у вас заполняется ? Что будет если документы перепровести не из формы ? Глючно уж больно ...
#12 by Valery
Иначе СМ А передать просто Провести(Переменная) ОбработкаПроведения(Переменная)
#13 by Danila
[9] Проблема в том, что реквизит не может быть списком, а у меня значения должно из списка выбираться. См. 10
#14 by Valery
а зачем сохранять весь список. Достаточно одного выбранного значения
#15 by Danila
[11] Этот документ не будет проводиться не из формы... Хотя это конечно стоит продумать, но на данном этапе надо чтоб хоть так заработало, это все равно промежуточный вариант.
#16 by Danila
[2] Интерактивно, только из формы.
#17 by Danila
Именно так... Только выбранное значение...
#18 by Warlock
2 Danila На списке ставишь формулу ИзмСписок
#19 by Danila
ТО Valery. Насколько я Вас понял в , реквизит создавать не нужно. В форме, в свойстве списка, Идентификатор = СуммаУслуга. Ее, я и выбираю. Т.о. в формуле свойств кнопки "провести" должно стоять "#Записать Провести(СуммаУслуга)"
#20 by Danila
2 Warlock_WW. Это в модуле документа надо, да?
#21 by laeg
Что бы провести документ он должен быть всегда записан, не пудрите мозги человеку ... в предопределенной процедуре ПриЗаписи просто вставить одну строчку МойРеквезит = МойСписок.ПолучитьЗначение(МойСписок.ТекущаяСтрока) вот и все ...
#22 by Danila
Сори. Эту процедуру в модуле формы надо писать... Лажанулся извиняюсь.
#23 by Warlock
Да, так будет лучше...
#24 by Danila
Соответственно, нужно все таки добавить реквизит.... Напрямую из списка не отправлять значение (см. 19)
#25 by Warlock
Ну конечно!
#26 by Danila
А нельзя сделать так, передать значение переменной из списка так: Процедура ПриЗаписи(СуммаУслуга) ... Сообщить("Передали значение "+СуммаУслуга+"в процедуру ПриЗаписи) ... КонецПроцедуры
#27 by Warlock
ПриЗаписи вызывается сама и без параметров. А почему именно так надо?
#28 by SnarkHunter
Данила, когда наступишь на грабли - вспомни об этой ветке... Кстати, фанатам аттестации -  с таким решением вряд ли вы ее пройдете...
#29 by Warlock
С каким решением? Почему?
#30 by laeg
ТО Можно, только вот так ПриЗаписи(СуммаУслуга) Процедура ПриЗаписи ... СуммаУслуга = СписокЗначений.ПолучитьЗначение(СписокЗначений.ТекущаяСтрока); Сообщить("Передали значение "+СуммаУслуга+"в процедуру ПриЗаписи) ... КонецПроцедуры
#31 by laeg
ТО Можно, только вот так Процедура ПриЗаписи ... СуммаУслуга = СписокЗначений.ПолучитьЗначение(СписокЗначений.ТекущаяСтрока); Сообщить("Передали значение "+СуммаУслуга+"в процедуру ПриЗаписи) ... КонецПроцедуры
#32 by SnarkHunter
С передачей переменной в модуль проведения и ее дальнейшим использованием при проведении...
#33 by Danila
Т.е. это как бы не секюрно с точки зрения юзера. Бухгалтер перепроведет, или програмно перепроведется документ и переменная не учтется. Так?
#34 by SnarkHunter
Ну вот, к 33 посту нащупали грабли в траве...
Тэги:
Ответить:
Комментарии доступны только авторизированным пользователям
Back to top