ТиС Регистр Покупатели #687324


#0 by prorokk
Доброй ночи Уважаемые... Прошу помочь разобраться... Есть база в ней RG4335.DBF(регистр покупатели) 2гб Как нагуглил в Этот файл Ежемесячно заносятся Остатки "Взаиморасчетов/долгов"... Просмотрел документы Есть 1) Реализация розница 2) ПКО (В них то указан документ основание, то нет, то на 10 Реализация один ПКО, и Вид оплаты То Розничная выручка, то оплата от покупателя) 3) И еще документы Корректировка долга (Юзали как Альтернативу ПКО О_о) Проблемам собственно в 2гб файле... ... Читал что в основном это из-за КредДокумент, якобы при проведение ПКО Регистр не закрывается... Но Решения найти так и не удалось.... Поделитесь опытом...
#1 by prorokk
Мне непонятна что Вообще должно быть там... Итак есть 5 реализаций на 5000руб Следом в этом же месяце ПКО на 500руб Провожу доки за 2 месяца, открываю "Долги" (dbf редактором) на Второй месяц там эти цифры и они дублируются и в 3-ий и в 4-ый месяц... и т.д. до 2гб....
#2 by КонецЦикла
Читай начиная с "обратить внимание на состояние данных"
#3 by КонецЦикла
Надо решиться и закрыть обработкой, а далее навести порядок у учете
#4 by v4442
Посмотри движению по документу  реализация и по оплате(ПКО или банк). По реализации возникает долг, по оплате списываестся долг.
#5 by v4442
Самая главная проблема пользователей - ПОСЛЕДОВАТЕЛЬНОСТЬ.
#6 by prorokk
Читал читал... до дыр зачитал... А как закрыть если сейчас  уже 2гб файлик... в него писать нельзя... файловая БД Ну в отчете... Увеличение,уменьшение долга все есть... Ну так скажем Начал копать с 2004 года доки... Вот первую пачку из 5 доков рассматриваю... вроде все Последовательно... + от себя... Мне Кажется что в моем случае... Не закрывались Реализации из-за разных Значений НП в документе Реализации и ПКО... заметил Всматриваясь в regprint, сейчас поправлю... перепроведу... и Утром отпишусь... Во Всяком случае в Регистре Появились строки с Красными -
#7 by prorokk
Ну вот первая победа... первые 5мес документов весят не 1016кб а 197кб... но все же весят... будем проверять дальше)) Сделанно: Ставка НП и КодОперации РозничнаяВыручка.
#8 by Artful Den
свернуть базу не предлагать?
#9 by КонецЦикла
Могу помочь навести порядок... Потому что писать все на свете и телепатировать задолбешься, нужна база
#10 by prorokk
я пять минут в DBF редакторе 01.01.13 года листал до 01.02.13... не долистал, палец затек... Думаю Свертка Решит проблему не на долго и Сворачивать придется прям До Позавчера... Огромное Спасибо за предложение! Обязательно обращусь, если не справлюсь за пару дней сам. Если можно подскажите про РКО у меня за первые пять мес сейчас В основном висят РКО РКО: Вид оплаты: Возврат покупателю Основание: Не Указанно Контрагент: Частное лицо НП выставил Галочку. Может что-то для РКО критично для правильного списания?
#11 by КонецЦикла
Надо сделать копию базы и просто и потренироваться Взять завести нового контрагента и ввести цепочку документов, 2-3 штуки (чтобы отвязаться от последовательностей и хвостов) Разобраться, изменить виды операций, заполнить правильно и снова провести в хронологическом порядке
#12 by Artful Den
судя по не выход
#13 by КонецЦикла
Там вообще непонятно... РКО.. ну что дальше? :)
#14 by Artful Den
если у ТС бардак с 2004 года, то имхо проще базу свернуть
#15 by КонецЦикла
Хвосты же ведь все равно придется переносить
#16 by Artful Den
хвосты потом закрыть
#17 by Злопчинский
Во всех документах установи УчитыватьНП=0. если есть еще галки, относящиеся к НП - установи их по смыслу "не учитывать НП". Перепроведи базу, можно перепроводить не всю базу, а выборочно - документы реализаций (разные!), документы оплат (пко/выпсики приход), корректировки долгов.
#18 by vcv
А НП в 2004 году разве еще не отменили? Предлагаю в RA4335 каким-нибудь приличным DBF-редактором тупо установить значение, соответствующее "не учитывать НП" и пересчитать итоги в конфигураторе. RG сразу станет кардинально меньше двух гигов, появится время спокойно разбираться с прочими косяками во взаиморасчетах, перепроведениями баловаться и всем прочим.
#19 by vcv
Вот тут пишут, что "С 1 января 2004 года налог с продаж в России не взимается". Так что можно в базе обработочкой установить всё, что касается НП в ноль, по регистрам DBF-редактором в движениях, итоги пересчитать конфигуратором.
Тэги: Админ
Ответить:
Комментарии доступны только авторизированным пользователям
Back to top