Проблема при переходе с БП 2.0 на 3.0 (не пашет отладчик) #724501


#0 by WF72
Привет уважаемым коллегам! Тестирую сейчас БП 3.0 после перехода с 2.0, конфа была нетиповая, но изменения почти все сделал в своих модулях и подписках. Пытаюсь зайти в "Параметры учета", так вылезает ошибка: {ОбщаяФорма.ПараметрыУчета.Форма}: Поле объекта не обнаружено (ВедетсяРозничнаяТорговля) Дай, думаю, запущу отладчик, узнаю хоть, что это за НаборКонстант такой. Опаньки, отладчик попросту не пашет, не останавливается на этой строке, как будто я никаких точек останова не ставил! Что за фигня, никто не знает? Ни один из общих модулей не снят с поддержки, все на замочках.
#1 by IamAlexy
-debug
#2 by Lys
В конфигураторе: Отладка - Подключение - кнопка Автоматическое подключение - тыркнуть галку "Фоновые задания"
#3 by cons74
теперь у тебя клиент-серверное соединение. А не просто толстый клиент. Теперь надо подключать тонкий клиент+сервер+фоновые (в отладке). И если стоит сервер1С - то его запускать с ключом как .
#4 by WF72
Большое спасибо за ответы. Век живи - век учись...
#5 by WF72
один небольшой вопрос остался. этот ключ пихать в параметр запуска службы Агента сервера 1С? сам сейчас проверить не могу: пользюков полно в базах, их же всех вырубит.
#6 by WF72
Короче, по сути проблемы. Помните, что в старых релизах БП 3.0 при обновлении нетиповых конф была туча глюков, к примеру не были прописаны обработчики событий у 5 подписок? Так вот, разрабы сглючили снова. У двух как минимум реквизитов общей формы ПараметрыУчета не стоит галка "использовать всегда". Только боженька знает, сколько косяков еще предстоит найти.
#7 by WF72
Люди, а у вас разве сохраняется этот параметр -debug в окошке параметров запуска службы? Это ж до первого рестарта, получается?
#8 by MaxS
не помню. Нетиповые обновлял через Конфигурация - Поддержка... да. В реестре правится.
#9 by Looser-1c
в реестр пиши. Всё сохраняеется
Тэги: 1С 8
Ответить:
Комментарии доступны только авторизированным пользователям

В этой группе 1С

Back to top